iis7 发布mvc3 遇到的HTTP错误 403.14-Forbidden Web 服务器被配置为不列出此目录的内容及Login on failed for "IIS APPPOOL\ASP.NET v4.0"问题(转http://www.cnblogs.com/Joans/archive/2011/02/18/1957648.html)

Coordinator
Nov 22, 2011 at 1:37 PM

1.发布mvc3报错:403.14-Forbidden Web 服务器被配置为不列出此目录的内容

折腾了半天,提示里面的解决方法是:

  • 如果不希望启用目录浏览,请确保配置了默认文档并且该文件存在。
  • 使用 IIS 管理器启用目录浏览。
    1. 打开 IIS 管理器。
    2. 在“功能”视图中,双击“目录浏览”。
    3. 在“目录浏览”页上,在“操作”窗格中单击“启用”。
  • 确认站点或应用程序配置文件中的 configuration/system.webServer/directoryBrowse@enabled 特性被设置为 True。

按照该方法改后 ,发现网页运行界面进去的变成了目录结构,后来发现改配置文件web.config配置文件的配置节后,网站就可以正常使用了,记录下哦。

<system.webServer>
    <validation validateIntegratedModeConfiguration="false" />
    <modules runAllManagedModulesForAllRequests="true" />
        <directoryBrowse enabled="false" />
  </system.webServer>

要设置<modules>节的值为true, 而目录浏览启用或禁用其实都没影响的。

2. 发布好后,登陆界面可以显示,跳转页面访问数据库时报错,Login on failed for "IIS APPPOOL\ASP.NET v4.0",发现是网页的“IIS APPPOOL\ASP.NET v4.0”无权限访问数据库,给数据库添加了用户登陆名为“IIS APPPOOL\ASP.NET v4.0” ,并添加了所有权限,就可以使用了。

操作详细过程:打开sqlserver manager studio, 在“安全性”-》”登录名“-》右击“新建登录名”-》在“常规”选择页填写登登录名“IIS APPPOOL\ASP.NET v4.0”-》在“服务器角色”选择页下选中所有角色权限,确定即可。

如图示:                                                       

                                            

如果还是不行,可是试试加一个登录名network service, 权限设置跟以上描述一样。

IIS配置Windows权限登录,页面老是报http 401.0的错误。  无权访问页面的错误。

添加了IUSR组 及用户的所有权限都还是同样的错误,  后来在配置IIS的时候发现windows身份验证及基本身份验证 没装

安装好后,重新启动iis服务就可以了。